Tu servidor está ejecutando la versión 4.4.7 de PHP, pero WordPess 3.3.1 necesita, al menos, la versión 5.2.4.